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Revision History 

Revision Date Description Initials 

1.0 8/21/17 First published version. CS 

1.1 8/3/18 Revised version for new interface (EAS 9.4) CS 

    

    

    

Purpose 

Refer to this guide to learn how to use NHC Premium Auto Attendant. 

Audience 

Information in this document is for people who use NHC newVoice Hosted PBX telephone 

systems. 

Reference 

Refer to the guide below for more information about NHC phone systems: 

Product Guide for newVoice Hosted PBX 
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Overview 
This quick reference guide covers the following topics related to Premium Auto Attendant: 

• What is an Auto Attendant? 

• Time and Day Routing 

• Auto Attendant Log In 

• Premium Attendant Icons 

• Premium Offering 

• Getting Started 

• Main Screen 

• Configuring Schedules 

• Menus 

• Announcements 

• Extensions 

• Advanced Features 

• Error Handling 

• Settings 

• Options When Auto Attendant Is Off 

• Help 
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What Does an Auto Attendant Do? 
An auto attendant is an automated answering system which provides a caller with options to 

select from, and then executes the option selected by the caller. Auto attendants mostly transfer 

callers to a destination without intervention of an operator or receptionist. Many auto 

attendants also offer a simple menu system: for sales, press 1; for service, press 2, and so on. 

Most auto attendants also allow callers to reach a live operator by dialing a number, usually 0. 

Operation 

The diagram below illustrates how the attendant transfers calls: 

 

Sample auto attendant message: 

Thank You for calling Bob's Fish Mart. We are open from 10 am to 9pm Monday through 

Friday.   

To speak to Customer Service, please press 1. For the Fish Department, please press 2.  For 

directions, please press 3. For our dial by name directory, please press 4. If you know your 

party’s extension, please press pound, followed by the extension. 
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Menu, Schedule, and Direct Dial 
Auto Attendant is intended for business group customers who want to provide an automated 

means of directing incoming calls to the appropriate person within the organization, typically to 

offload this task from a receptionist. 

The service comprises four main elements:  

• A hierarchy of menus that enable callers to choose from a list of options. These options 

direct the caller to the most appropriate department or person within the organization 

to handle that type of call, or to a number outside the business group if appropriate.  

• A schedule of business hours and holidays that controls the presentation of menus, so 

you can present a different set of announcements and menus outside business hours, 

and during defined special days.  

• A call routing capability that enables callers to reach a person in the organization directly 

by entering the individual’s extension. 

• A dial-by-name capability that enables a caller to reach a person in the organization 

directly by entering the first few letters of the individual’s name.  

You can create different menus for different times of the day and week. These menus play 

according to a pre-defined schedule you create. For example: 

Welcome to Bob's Fish Mart. Unfortunately, we are currently closed. To hear directions to our 

store, press 1. To hear our operating hours, press 2. If you wish to leave a message, press 3. We 

will call you back as soon as possible.  

After you set up Auto Attendant and record necessary announcements, the attendant 

automatically plays the correct menu for callers, depending on when the call comes in. 

The flow chart below illustrates how the attendant handles calls in one way during business 

hours, and another way after business hours. 
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Auto Attendant – Login 
Log into Auto Attendant via NHC’s CommPortal. Follow these steps: 

1. Point your browser to https://commportal.nhcgrp.com/. 

 

2. Enter the number assigned to the Premium Auto Attendant. 

3. Enter the default CommPortal password the first time you log in. 

After you log in, CommPortal prompts you to change your password. 
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Alternately, log into CommPortal as an administrator, then open Auto Attendant’s main screen: 

1. Point your browser to https://commportal.nhcgrp.com/bg/. 

2. Enter your administrator’s credentials in the Number and Password fields. 

3. In the administrative portal, enter auto in the Search For… field above the list of phone 

numbers. 

All numbers configured as Auto Attendant numbers appear. 

4. Click the Actions drop-down list on the right for the desired Auto Attendant number. 

5. Select View attendant settings from the list. 

The Auto Attendant Main screen opens. 
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Getting Started 
To set up an auto attendant, first open the Line Status pane for the desired attendant: 

1. Log into your Business Group Admin Portal: 
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2. Click Attendants in the left menu, or click the Attendants icon under All Lines. 

The Attendants pane opens: 

 

3. Click the Actions drop-down list for the desired Auto Attendant number, then select View 

attendant settings: 
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The attendant’s Home pane appears: 

 

4. Click Open Attendant Settings on the right. 
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The Main tab of the Line Status pane appears: 
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Main Screen 
Auto Attendant’s Main tab appears below: 

 
Using the Main screen’s tabs and controls, you can accomplish these tasks: 

• Turn Auto Attendant on or off. 

• Configure the attendant’s schedule. 

• Configure menus offered callers during different periods you create.  

• Record announcements your callers hear, for menu options that require announcements.  

• Configure extensions your callers dial if you offer these options: 

o Dial by Extension 

o Dial by Name 

o Voicemail by Extension 

o Voicemail by Name 

• Change default settings for keys used in your menus. 

• Change the way Auto Attendant handles errors.  
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Configure Schedules 

You can configure up to eight Auto Attendant schedule periods. 

For example, you might create: 

• One schedule for normal business hours. 

• A second schedule to cover the lunch period. 

• An out-of-hours schedule for when your business is closed.  

Create a separate menu for each of the schedules you define. 

Auto Attendant’s Schedule tab appears below: 
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Add a New Time Period 

To add a new time period for your Auto Attendant’s schedule: 

1. Click the Schedule tab in Auto Attendant’s Line Status pane: 

 

2. Click Add New Period at the upper left. 

A dialog box prompts you to enter a name for the new period: 
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3. Enter the period’s name, then click OK. 

The new period, named Off Hours in this example, appears in the Schedule tab under 

Periods. Until you apply a menu, the period name displays an error icon: 
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4. Select a menu from the Select menu… drop-down list above the schedule on the right, 

then click Apply at the upper right. 

The new period appears in the Periods list on the left: 
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To remove a period from the Periods list: 

1. Select the desired period in the Periods list. 

2. Click Delete above the schedule. 

A dialog box prompts you to confirm delete: 

 

3. Click OK. 

The period no longer appears in the Periods list. 
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Define a Schedule 
To define a weekly schedule: 

1. Click the Schedule tab in Auto Attendant’s Line Status pane. 

2. Select the desired period in the Periods list. 

For example, select Lunch in blue. 

3. Click the desired lunch hours in the schedule on the right. 

In the example below, Lunch is set for 12:00 – 1:00 PM, Monday through Friday. 

 

4. Click Apply at the upper right when desired periods are in place. 

Select All other times in the Periods list for hours and days not defined in any of your other 

periods. This category appears white on your weekly schedule. 

Select Special Days in the Periods list to designate public holidays and other special days when 

your business is closed. 
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Create a Menu for a Period 
To create a menu for a period: 

1. Click the Schedule tab in Auto Attendant’s Line Status pane. 

2. In the Select menu… drop-down list above the weekly schedule, select Create New 

Menu…. 

 

Note: Create New Menu… is available in the Select Menu… drop-down list only when Auto 

Attendant is off. Turn Auto Attendant on and off in the Main tab. 
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A dialog box prompts you to choose a name for the new menu: 

 

3. Enter a name for the new menu, and if desired, a description. Then click OK. 

For example, name the menu Working Hours Menu, if you plan to assign it to the 

Working Hours period in the schedule. 

The new menu name appears in the Select Menu… drop-down list. 
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Assign Menu to Period 
To assign the new menu to the selected period: 

1. Click the Schedule tab in Auto Attendant’s Line Status pane. 

2. Select the desired period in the Periods list. 

3. Select the menu to assign to the period in the Select Menu… drop-down list. 

 

4.  Click Apply at the upper right to save the assignment. 
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Menus 
Your Auto Attendant menu configuration determines the options offered to callers, and what 

announcements they hear. 

Each schedule period must have an associated menu before you turn Auto Attendant on. For 

each period in the Schedule tab’s Periods list, choose an existing menu from the drop-down list, 

or select Create New Menu… from the drop-down list. If you select Create New Menu…, a 

prompt opens to enter a name and description for the menu. Configure the new menu and its 

announcements later in the setup process. 

 

Note: You can add a new menu only when the attendant is off. 
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Menus – General 
To change a menu name or description: 

1. Click the Menus tab in the Auto Attendant Line Status pane. 

The Menus tab opens to General tab right of the Menus list. 

 

2. Select the desired menu in the Menus list. 

3. Enter a new name in the Name field. 

4. Enter a new description in the Description field. 

5. Click Apply at the upper right. 

The new name appears in the Menus list on the left. 
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Menus – Keys 
To assign actions to the keys a caller can press to navigate a specific menu: 

1. Click the Menus tab in the Auto Attendant Line Status pane. 

2. Click the desired menu in the Menus list. 

For example, select Working Hours Menu. 

3. Click Keys above the right-hand pane. 

A list of keys on the keypad appears. 

 

5. Use the drop-down list for each key to select the action you want to assign to that key. 

See the list of options for each key below. 

6. Click Apply at the upper right to save your changes. 

  



 

26 

Select from these options in the drop-down list for each key: 

• Use Default 

• Transfer to Phone 

• Transfer to Voicemail 

• Dial by Extension 

• Dial by Name 

• Voicemail by Extension 

• Voicemail by Name 

• Intercept Mailbox 

• Go to Menu 

• Return to Previous Menu 

• Replay Menu 

• Announcement – Return 

• Announcement Hang-up 

• Hang-up 
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Menus – Timeout 
Click Timeout above the right-hand pane to specify the action to take if a caller fails to: 

• Press a key 

• Select a valid extension 

• Select a valid name from the directory 

To specify a timeout action: 

1. Click the Menus tab in the Auto Attendant Line Status pane. 

2. In the Menus list, select the menu you want to assign the timeout function to. 

3. Click Timeout above the right-hand pane. 

 

4. Check Override timeout behavior. 

5. Set the timeout duration in seconds in the first drop-down list. 

6. Select the action to take after time elapses in the second drop-down list. 

7. Click Apply at the upper right to save your changes. 
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Menus – References 
Click References above the right-hand pane to list schedule periods that refer to the menu 

selected on the left. In the image below, the Working Hours period in the Schedule tab refers to 

the Working Hours Menu: 
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Announcements 
The Announcements tab lists all the announcements created as you set up your menu 

configuration. Icons indicate the status of each announcement.   

The list stores up to 300 items. If required, use the search field to find the announcement you 

wish to edit. To perform a search, type all or part of the announcement’s name, description, or 

number. 
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To remove an announcement from the list: 

1. In the left-hand column, check the box for the announcement you want to delete. 

2. Click Delete above the list. 

A Confirm delete pane appears: 

 
3. Click OK.  

The announcement no longer appears in the list. 

To download a CSV file with detailed information for all your announcements: 

1. Click Download recording report…. 

A Recording report pane appears: 

 
2. Click OK. 

The Export status bar shows progress of the download.  
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Announcement Icons 

Click the Announcements tab to display icons that indicate an announcement’s status: 

Icon 
Icon 

Name 
Indication 

 Play Recording exists for the announcement: click icon to play. 

 Record 
Recording does not exist for the announcement: click icon 

to record. 

 Information 
One or more menus refer to the announcement: hover over 

the icon to view the menus. 

 Warning No menu refers to the announcement. 

 Error 
Menu refers to the announcement, but no announcement is 

recorded. 

The image below displays icons for two announcements, AA and Skysone test: 
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Add a New Announcement 
To add an announcement: 

1. Click the Announcements tab in the Auto Attendant Line Status pane. 

 

  



 

33 

2. In the Announcements tab, click Add New Announcement at the upper left. 

The Add Announcement pane appears: 

 

Record / Play Announcement is the default selection in the drop-down list. 

3. Enter a name and optional description for the announcement. 

4. Click the red record button on the left, and record the announcement with a 

microphone. 

Alternately, select Upload announcement in the drop-down list to upload a pre-recorded 

announcement, or select Record by Phone in the drop-down list to record the 

announcement from a telephone. 

5. Click Add at the lower right to save the announcement. 
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Extensions 
Auto Attendant can offer callers these options: 

• Dial by Extension 

• Dial by Name 

• Voicemail by Extension 

• Voicemail by Name  

If you offer your callers these options, you must configure the set of extensions they can dial. To 

do so, click the Extensions tab in the Line Status pane, then click Business Group Extensions or 

Additional Extensions. 
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Spoken Name 
Each line in the business group can use a spoken name for that line’s voicemail greeting. Links 

for spoken name greetings appear in the Spoken Name column of the Extensions tab: 

 

The table below lists the links that can appear in the Spoken Name column: 

Link Recording Status Action 

Green override 
Personal name is 

recorded for the line. 

Click override to record the business group’s 

name for the line, to play in place of the 

personal name. 

Red record 
No name is recorded for 

the line. 

Click record to record a business group name 

for the line. 

Green 

listen/change 
Business group name is 

recorded for the line. 

Click listen/change to listen to your current 

recording and delete it, or replace it with a new 

recording. 
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Add Business Group Extensions 
To use extensions, you must define the set of extensions callers can dial.  

For each extension, specify the three- or four-digit extension, the extension name, and the ten-

digit phone number associated with the extension. 

To add a new extension: 

1. Click the Extensions tab in the Auto Attendant Line Status pane. 

2. Click Additional Extensions. 
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3. Click Add Extension at the upper right. 

The Add Extension pane appears: 

 
4. Select Name and Number. 

The Edit Extension pane appears: 

 

5. Enter the extension number. 

6. Enter the first and last name. 

7. Enter the telephone number. 

8. Select Record Spoken Name to record the spoken name using a microphone on your PC, 

or select Upload Spoken Name to upload the name from a file saved on your computer. 

9. Click Save at the lower right. 

The new extension appears in the Extensions tab.  
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Advanced 
Use the Advanced tab to enter settings for: 

• Default keys 

• Error handling 

• Other settings 

The Advanced tab opens to the Default keys page: 
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Default Keys 
Click Default keys in the Advanced tab to assign default actions to selected keys on the keypad. 

If you assign a default action, callers can press the key during any menu recording to initiate 

that action. When Do Nothing is assigned to a key, the system tells callers the option is not 

recognized. 

You can assign one of these default actions to each key: 

• Do Nothing 

• Transfer to Phone  

• Transfer to Voicemail  

• Transfer to Operator  

• Intercept Mailbox  

• Dial by Extension  

• Return to Previous Menu  

• Replay Menu 
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Error Handling 
Click Error handling in the Advanced tab to change settings that specify how to respond to 

these errors: 

• Timeout 

• Call Transfer 

• Invalid Extension 

Use the drop-down lists in each heading to modify settings, then click Apply at the upper right 

to save your changes. 
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Other Settings 
Click Other Settings in the Advanced tab to select your Dial by Name preference, or set the 

number for your Intercept Mailbox: 

Dial by name – When a caller dials the name of the extension or mailbox they wish to reach, 

match the entry against configured extensions based on: 

• First and last name (default) 

• First name only 

• Last name only 

Intercept Mailbox – Direct your callers to the voicemail box associated with the number you 

enter. 

 

  



 

42 

Activation Status 
To turn the attendant on or off, click the Main tab in the Auto Attendant Line Status pane. The 

left column details Auto Attendant’s current status. 

To change Auto Attendant’s status, click Turn ON or Turn OFF under Activation Status. 
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Options When Auto Attendant Is Off 
When Auto Attendant is off, you can specify how the system handles incoming calls: 

1. Click the Main tab in the Auto Attendant Line Status pane. 

2. Click the link under Activation Status to open the Forwarding Number pane: 

 
3. Select one of two options: 

• Play a message to tell callers the number is unreachable, or 

• Forward callers to a specified number.  

4. Click Apply to save your change. 
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Premium Attendant vs. Easy 
Attendant 
CommPortal has two versions of Auto Attendant: Premium Attendant and Easy Attendant. These 

icons designates the Auto Attendant version for a given line: 

Icon Auto Attendant Version 

 Premium Attendant 

 Easy Attendant 

Premium Attendant 

Settings for Premium Attendant appear in the familiar Line Status pane: 

 

The instructions in this guide follow Premium Attendant workflows. 
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Easy Attendant 

Settings for Easy Attendant appear in a simplified Line Status pane: 

 

Workflows in this pane simplify the setup process for Auto Attendant. 
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Corporate Office: 
420 Bedford Street 
Suite 250 
Lexington, MA 02420 
855-600-4NHC (4642) 
 
Customer Operations: 
6836 International Center Blvd. 
Fort Myers, FL 33912 
24x7x365  Service: 
855-600-4NHC (4642) 
 
Email & Web: 
info@nhcgrp.com 
www.nhcgrp.com 
 

mailto:info@nhcgrp.com
http://www.nhcgrp.com/

